What’s Vulnerable › Vulnerabilities
CVE-2022-36090: org.xwiki.platform:xwiki-platform-oldcore Improper Authorization check for inactive users
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-08 · updated 2026-06-17
- Weakness: CWE-285
Description
XWiki Platform Old Core is a core package for XWiki Platform, a generic wiki platform. Prior to versions 13.1.0.5 and 14.3-rc-1, some resources are missing a check for inactive (not yet activated or disabled) users in XWiki, including the REST service. This means a disabled user can enable themselves using a REST call. On the same way some resources handler created by extensions are not protected by default, so an inactive user could perform actions for such extensions. This issue has existed since at least version 1.1 of XWiki for instance configured with the email activation required for new users. Now it's more critical for versions 11.3-rc-1 and later since the maintainers provided the capability to disable user without deleting them and encouraged using that feature. XWiki 14.3-rc-1 and XWiki 13.10.5 contain a patch. There is no workaround for this other than upgrading XWiki.
Affected products
- xwiki-platform: from 1.1 before 13.10.5 — fixed in 13.10.5
How to fix
Upgrade to a fixed version: xwiki-platform 13.10.5. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/e074d226d9b2b96a0a1ba4349d1b73a802842986
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-jgc8-gvcx-9vfx
- https://jira.xwiki.org/browse/XWIKI-19559
- https://github.com/xwiki/xwiki-platform/commit/e074d226d9b2b96a0a1ba4349d1b73a802842986
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-jgc8-gvcx-9vfx
- https://jira.xwiki.org/browse/XWIKI-19559
Get alerted when CVE-2022-36090 or the next vulnerability affects your stack