What’s Vulnerable › Vulnerabilities
CVE-2022-36096: XWiki Platform vulnerable to Cross-site Scripting in the deleted attachments list
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 60.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The XWiki Platform Index UI is an Index of all pages, attachments, orphans and deleted pages and attachments for XWiki Platform, a generic wiki platform. Prior to versions 13.10.6 and 14.3, it's possible to store JavaScript which will be executed by anyone viewing the deleted attachments index with an attachment containing javascript in its name. This issue has been patched in XWiki 13.10.6 and 14.3. As a workaround, modify fix the vulnerability by editing the wiki page `XWiki.DeletedAttachments` with the object editor, open the `JavaScriptExtension` object and apply on the content the changes that can be found on the fix commit.
Affected products
- xwiki-platform: from 2.3 before 13.10.6; from 14.0 before 14.3; 2.2-milestone1 — fixed in 13.10.6, 14.3
How to fix
Upgrade to a fixed version: xwiki-platform 13.10.6, 14.3. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/6705b0cd0289d1c90ed354bd4ecc1508c4b25745
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-gjmq-x5x7-wc36
- https://jira.xwiki.org/browse/XWIKI-19613
- https://github.com/xwiki/xwiki-platform/commit/6705b0cd0289d1c90ed354bd4ecc1508c4b25745
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-gjmq-x5x7-wc36
- https://jira.xwiki.org/browse/XWIKI-19613
Get alerted when CVE-2022-36096 or the next vulnerability affects your stack