What’s Vulnerable › Vulnerabilities
CVE-2022-36097: XWiki Platform Attachment UI vulnerable to cross-site scripting in the move attachment form
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 58.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-08 · updated 2026-06-17
- Weakness: CWE-79
Description
XWiki Platform Attachment UI provides a macro to easily upload and select attachments for XWiki Platform, a generic wiki platform. Starting with version 14.0-rc-1 and prior to 14.4-rc-1, it's possible to store JavaScript in an attachment name, which will be executed by anyone trying to move the corresponding attachment. This issue has been patched in XWiki 14.4-rc-1. As a workaround, one may copy `moveStep1.vm` to `webapp/xwiki/templates/moveStep1.vm` and replace vulnerable code with code from the patch.
Affected products
- xwiki-platform: from 14.0 before 14.3 — fixed in 14.3
How to fix
Upgrade to a fixed version: xwiki-platform 14.3. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/fbc4bfbae4f6ce8109addb281de86a03acdb9277
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-9r9j-57rf-f6vj
- https://jira.xwiki.org/browse/XWIKI-19667
- https://raw.githubusercontent.com/xwiki/xwiki-platform/xwiki-platform-14.0-rc-1/xwiki-platform-core/xwiki-platform-attachment/xwiki-platform-attachment-api/src/main/resources/templates/attachment/moveStep1.vm
- https://github.com/xwiki/xwiki-platform/commit/fbc4bfbae4f6ce8109addb281de86a03acdb9277
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-9r9j-57rf-f6vj
- https://jira.xwiki.org/browse/XWIKI-19667
- https://raw.githubusercontent.com/xwiki/xwiki-platform/xwiki-platform-14.0-rc-1/xwiki-platform-core/xwiki-platform-attachment/xwiki-platform-attachment-api/src/main/resources/templates/attachment/moveStep1.vm
Get alerted when CVE-2022-36097 or the next vulnerability affects your stack