What’s Vulnerable › Vulnerabilities
CVE-2022-36101: Sensitive data in backend customer module
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-12 · updated 2026-06-17
- Weakness: CWE-200
Description
Shopware is an open source e-commerce software. In affected versions the request for the customer detail view in the backend administration contained sensitive data like the hashed password and the session ID. These fields are now explicitly unset in version 5.7.15. Users are advised to update and may get the update either via the Auto-Updater or directly via the download overview. There are no known workarounds for this issue.
Affected products
- shopware: from 5.0.0 before 5.7.15 — fixed in 5.7.15
How to fix
Upgrade to a fixed version: shopware 5.7.15. Check the vendor advisory for mitigations.
References
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-09-2022
- https://github.com/shopware/shopware/commit/af5cdbc81d60f21b728e1433aeb8837f25938d2a
- https://github.com/shopware/shopware/security/advisories/GHSA-6vfq-jmxg-g58r
- https://packagist.org/packages/shopware/shopware
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-09-2022
- https://github.com/shopware/shopware/commit/af5cdbc81d60f21b728e1433aeb8837f25938d2a
- https://github.com/shopware/shopware/security/advisories/GHSA-6vfq-jmxg-g58r
- https://packagist.org/packages/shopware/shopware
Get alerted when CVE-2022-36101 or the next vulnerability affects your stack