What’s Vulnerable › Vulnerabilities
CVE-2022-36107: Stored Cross-Site Scripting via FileDumpController
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-13 · updated 2026-06-17
- Weakness: CWE-79
Description
TYPO3 is an open source PHP based web content management system released under the GNU GPL. It has been discovered that the `FileDumpController` (backend and frontend context) is vulnerable to cross-site scripting when malicious files are displayed using this component. A valid backend user account is needed to exploit this vulnerability. Update to TYPO3 version 7.6.58 ELTS, 8.7.48 ELTS, 9.5.37 ELTS, 10.4.32 or 11.5.16 that fix the problem. There are no known workarounds for this issue.
Affected products
- typo3: from 7.0.0 through 7.6.57; from 8.0.0 through 8.7.47; from 9.0.0 through 9.5.36; from 10.0.0 through 10.4.31; from 11.0.0 through 11.5.15
References
- https://github.com/TYPO3/typo3/commit/bd58d2ff2eeef89e63ef754a2389597d22622a39
- https://github.com/TYPO3/typo3/security/advisories/GHSA-9c6w-55cp-5w25
- https://typo3.org/security/advisory/typo3-core-sa-2022-009
- https://github.com/TYPO3/typo3/commit/bd58d2ff2eeef89e63ef754a2389597d22622a39
- https://github.com/TYPO3/typo3/security/advisories/GHSA-9c6w-55cp-5w25
- https://typo3.org/security/advisory/typo3-core-sa-2022-009
Get alerted when CVE-2022-36107 or the next vulnerability affects your stack