What’s Vulnerable › Vulnerabilities
CVE-2022-36108: Cross-Site Scripting in typo3/cms-core
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-13 · updated 2026-06-17
- Weakness: CWE-79
Description
TYPO3 is an open source PHP based web content management system released under the GNU GPL. It has been discovered that the `f:asset.css` view helper is vulnerable to cross-site scripting when user input is passed as variables to the CSS. Update to TYPO3 version 10.4.32 or 11.5.16 that fix the problem. There are no known workarounds for this issue.
Affected products
- typo3: from 10.0.0 through 10.4.31; from 11.0.0 through 11.5.15
References
- https://github.com/TYPO3/typo3/commit/6863f73818c36b0b88c677ba533765c8074907b4
- https://github.com/TYPO3/typo3/security/advisories/GHSA-fv2m-9249-qx85
- https://typo3.org/security/advisory/typo3-core-sa-2022-010
- https://github.com/TYPO3/typo3/commit/6863f73818c36b0b88c677ba533765c8074907b4
- https://github.com/TYPO3/typo3/security/advisories/GHSA-fv2m-9249-qx85
- https://typo3.org/security/advisory/typo3-core-sa-2022-010
Get alerted when CVE-2022-36108 or the next vulnerability affects your stack