What’s Vulnerable › Vulnerabilities
CVE-2022-36110: Netmaker vulnerable to Insufficient Granularity of Access Control
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-09 · updated 2026-06-17
- Weakness: CWE-285
Description
Netmaker makes networks with WireGuard. Prior to version 0.15.1, Improper Authorization functions lead to non-privileged users running privileged API calls. If someone adds users to the Netmaker platform who do not have admin privileges, they can use their auth tokens to run admin-level functions via the API. This problem has been patched in v0.15.1.
Affected products
- gravitl netmaker: before 0.15.1 — fixed in 0.15.1
How to fix
Upgrade to a fixed version: gravitl netmaker 0.15.1. Check the vendor advisory for mitigations.
References
- https://github.com/gravitl/netmaker/releases/tag/v0.15.1
- https://github.com/gravitl/netmaker/security/advisories/GHSA-ggf6-638m-vqmg
- https://github.com/gravitl/netmaker/releases/tag/v0.15.1
- https://github.com/gravitl/netmaker/security/advisories/GHSA-ggf6-638m-vqmg
Get alerted when CVE-2022-36110 or the next vulnerability affects your stack