What’s Vulnerable › Vulnerabilities
CVE-2022-36111: immundb has insufficient verification of data authenticity
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-23 · updated 2026-06-17
- Weakness: CWE-345
Description
immudb is a database with built-in cryptographic proof and verification. In versions prior to 1.4.1, a malicious immudb server can provide a falsified proof that will be accepted by the client SDK signing a falsified transaction replacing the genuine one. This situation can not be triggered by a genuine immudb server and requires the client to perform a specific list of verified operations resulting in acceptance of an invalid state value. This vulnerability only affects immudb client SDKs, the immudb server itself is not affected by this vulnerability. This issue has been patched in version 1.4.1.
Affected products
- codenotary immudb: before 1.4.1 — fixed in 1.4.1
How to fix
Upgrade to a fixed version: codenotary immudb 1.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/codenotary/immudb/releases/tag/v1.4.1
- https://github.com/codenotary/immudb/security/advisories/GHSA-672p-m5jq-mrh8
- https://github.com/codenotary/immudb/tree/master/docs/security/vulnerabilities/linear-fake
- https://pkg.go.dev/github.com/codenotary/immudb/pkg/client
- https://github.com/codenotary/immudb/releases/tag/v1.4.1
- https://github.com/codenotary/immudb/security/advisories/GHSA-672p-m5jq-mrh8
- https://github.com/codenotary/immudb/tree/master/docs/security/vulnerabilities/linear-fake
- https://pkg.go.dev/github.com/codenotary/immudb/pkg/client
Get alerted when CVE-2022-36111 or the next vulnerability affects your stack