What’s Vulnerable › Vulnerabilities
CVE-2022-36112: Blind Server-Side Request Forgery (SSRF) in GLPI
- Severity: medium (CVSS 5.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-14 · updated 2026-06-17
- Weakness: CWE-918
Description
GLPI stands for Gestionnaire Libre de Parc Informatique and is a Free Asset and IT Management Software package, that provides ITIL Service Desk features, licenses tracking and software auditing. Usage of RSS feeds or extenal calendar in planning is subject to SSRF exploit. Server-side requests can be used to scan server port or services opened on GLPI server or its private network. Queries responses are not exposed to end-user (blind SSRF). Users are advised to upgrade to version 10.0.3 to resolve this issue. There are no known workarounds.
Affected products
- glpi-project glpi: before 10.0.3 — fixed in 10.0.3
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/commit/ad66d69049ae02bead8ed0f4ee654a458643244e
- https://github.com/glpi-project/glpi/security/advisories/GHSA-rqgx-gqhp-x8vv
- https://github.com/glpi-project/glpi/commit/ad66d69049ae02bead8ed0f4ee654a458643244e
- https://github.com/glpi-project/glpi/security/advisories/GHSA-rqgx-gqhp-x8vv
Get alerted when CVE-2022-36112 or the next vulnerability affects your stack