What’s Vulnerable › Vulnerabilities
CVE-2022-36124: Memory overconsumption in Avro Rust SDK
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-09 · updated 2026-06-23
- Weakness: CWE-770
Description
It is possible for a Reader to consume memory beyond the allowed constraints and thus lead to out of memory on the system. This issue affects Rust applications using Apache Avro Rust SDK prior to 0.14.0 (previously known as avro-rs). Users should update to apache-avro version 0.14.0 which addresses this issue.
Affected products
- Apache Software Foundation Apache Avro: before 0.14.0 — fixed in 0.14.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Avro 0.14.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/kj429rzo1xxjgz058qqqg0y7c0p512zo
- https://lists.apache.org/thread/kj429rzo1xxjgz058qqqg0y7c0p512zo
Get alerted when CVE-2022-36124 or the next vulnerability affects your stack