What’s Vulnerable › Vulnerabilities
CVE-2022-36125: Integer overflow when reading corrupted .avro file in Avro Rust SDK
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-09 · updated 2026-06-17
- Weakness: CWE-20
Description
It is possible to crash (panic) an application by providing a corrupted data to be read. This issue affects Rust applications using Apache Avro Rust SDK prior to 0.14.0 (previously known as avro-rs). Users should update to apache-avro version 0.14.0 which addresses this issue.
Affected products
- Apache Software Foundation Apache Avro: before 0.14.0 — fixed in 0.14.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Avro 0.14.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/t1r5xz0pvhm4tosqopjpj6dz8zlsht07
- https://lists.apache.org/thread/t1r5xz0pvhm4tosqopjpj6dz8zlsht07
Get alerted when CVE-2022-36125 or the next vulnerability affects your stack