What’s Vulnerable › Vulnerabilities
CVE-2022-36129
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-26 · updated 2026-06-17
- Weakness: CWE-306
Description
HashiCorp Vault Enterprise 1.7.0 through 1.9.7, 1.10.4, and 1.11.0 clusters using Integrated Storage expose an unauthenticated API endpoint that could be abused to override the voter status of a node within a Vault HA cluster, introducing potential for future data loss or catastrophic failure. Fixed in Vault Enterprise 1.9.8, 1.10.5, and 1.11.1.
Affected products
- HashiCorp Vault: from 1.7.0 through 1.9.7; from 1.10.0 through 1.10.4; 1.11.0
References
- https://discuss.hashicorp.com
- https://discuss.hashicorp.com/t/hcsec-2022-15-vault-enterprise-does-not-verify-existing-voter-status-when-joining-an-integrated-storage-ha-node/42420
- https://security.netapp.com/advisory/ntap-20220901-0011/
- https://discuss.hashicorp.com
- https://discuss.hashicorp.com/t/hcsec-2022-15-vault-enterprise-does-not-verify-existing-voter-status-when-joining-an-integrated-storage-ha-node/42420
- https://security.netapp.com/advisory/ntap-20220901-0011/
Get alerted when CVE-2022-36129 or the next vulnerability affects your stack