What’s Vulnerable › Vulnerabilities
CVE-2022-36130
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-01 · updated 2026-06-17
- Weakness: CWE-345
Description
HashiCorp Boundary up to 0.10.1 did not properly perform data integrity checks to ensure the resources were associated with the correct scopes, allowing potential privilege escalation for authorized users of another scope. Fixed in Boundary 0.10.2.
Affected products
- HashiCorp Boundary: before 0.10.2 — fixed in 0.10.2
How to fix
Upgrade to a fixed version: HashiCorp Boundary 0.10.2. Check the vendor advisory for mitigations.
References
- https://discuss.hashicorp.com
- https://discuss.hashicorp.com/t/hcsec-2022017-boundary-allowed-access-to-host-sets-and-credential-sources-for-authorized-users-of-another-scope/43493
- https://discuss.hashicorp.com
- https://discuss.hashicorp.com/t/hcsec-2022017-boundary-allowed-access-to-host-sets-and-credential-sources-for-authorized-users-of-another-scope/43493
Get alerted when CVE-2022-36130 or the next vulnerability affects your stack