What’s Vulnerable › Vulnerabilities
CVE-2022-3614
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-03 · updated 2026-06-17
- Weakness: CWE-601
Description
In affected versions of Octopus Deploy users of certain browsers using AD to sign-in to Octopus Server were able to bypass authentication checks and be redirected to the configured redirect url without any validation.
Affected products
- Octopus Deploy Octopus Server: from 3.5 before 2022.3.10750; from 2022.4 before 2022.4.8063 — fixed in 2022.3.10750, 2022.4.8063
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2022.3.10750, 2022.4.8063. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2022/sa2022-26/
- https://advisories.octopus.com/post/2022/sa2022-26/
Get alerted when CVE-2022-3614 or the next vulnerability affects your stack