What’s Vulnerable › Vulnerabilities
CVE-2022-36227
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-22 · updated 2026-10-08
- Weakness: CWE-476
Description
In libarchive before 3.6.2, the software does not check for an error after calling calloc function that can return with a NULL pointer if the function fails, which leads to a resultant NULL pointer dereference. NOTE: the discoverer cites this CWE-476 remark but third parties dispute the code-execution impact: "In rare circumstances, when NULL is equivalent to the 0x0 memory address and privileged code can access it, then writing or reading memory is possible, which may lead to code execution."
Affected products
- Debian Linux: 10.0
- Fedoraproject Fedora: 37
- libarchive: from 3.0.0 before 3.6.2 — fixed in 3.6.2
- Splunk Universal Forwarder: from 8.2.0 before 8.2.12; from 9.0.0 before 9.0.6; 9.1.0 — fixed in 8.2.12, 9.0.6
How to fix
Upgrade to a fixed version: libarchive 3.6.2; Splunk Universal Forwarder 8.2.12, 9.0.6. Check the vendor advisory for mitigations.
References
- https://bugs.gentoo.org/882521
- https://github.com/libarchive/libarchive/blob/v3.0.0a/libarchive/archive_write.c#L215
- https://github.com/libarchive/libarchive/issues/1754
- https://lists.debian.org/debian-lts-announce/2023/01/msg00034.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/V67OO2UUQAUJS3IK4JZPF6F3LUCBU6IS/
- https://security.gentoo.org/glsa/202309-14
- https://bugs.gentoo.org/882521
- https://github.com/libarchive/libarchive/blob/v3.0.0a/libarchive/archive_write.c#L215
- https://github.com/libarchive/libarchive/issues/1754
- https://lists.debian.org/debian-lts-announce/2023/01/msg00034.html
- https://lists.debian.org/debian-lts-announce/2024/11/msg00007.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/V67OO2UUQAUJS3IK4JZPF6F3LUCBU6IS/
Get alerted when CVE-2022-36227 or the next vulnerability affects your stack