What’s Vulnerable › Vulnerabilities
CVE-2022-3625: Linux Kernel IPsec devlink.c devlink_param_get use after free
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-21 · updated 2026-10-14
- Weakness: CWE-119
Description
A vulnerability was found in Linux Kernel. It has been classified as critical. This affects the function devlink_param_set/devlink_param_get of the file net/core/devlink.c of the component IPsec. The manipulation leads to use after free. It is recommended to apply a patch to fix this issue. The identifier VDB-211929 was assigned to this vulnerability.
Affected products
- Debian Linux: 10.0
- Linux kernel: from 4.19 before 5.4.211; from 5.5 before 5.10.138; from 5.11 before 5.15.63; from 5.16 before 5.19.4 — fixed in 5.10.138, 5.15.63, 5.19.4, 5.4.211
How to fix
Upgrade to a fixed version: Linux kernel 5.10.138, 5.15.63, 5.19.4, 5.4.211. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/pub/scm/linux/kernel/git/klassert/ipsec-next.git/commit/?id=6b4db2e528f650c7fb712961aac36455468d5902
- https://lists.debian.org/debian-lts-announce/2022/11/msg00001.html
- https://vuldb.com/?id.211929
- https://git.kernel.org/pub/scm/linux/kernel/git/klassert/ipsec-next.git/commit/?id=6b4db2e528f650c7fb712961aac36455468d5902
- https://lists.debian.org/debian-lts-announce/2022/11/msg00001.html
- https://vuldb.com/?id.211929
- https://cert-portal.siemens.com/productcert/html/ssa-794697.html
Get alerted when CVE-2022-3625 or the next vulnerability affects your stack