What’s Vulnerable › Vulnerabilities
CVE-2022-36368
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-24 · updated 2026-06-17
- Weakness: CWE-79
Description
Multiple stored cross-site scripting vulnerabilities in the web user interface of IPFire versions prior to 2.27 allows a remote authenticated attacker with administrative privilege to inject an arbitrary script.
Affected products
- IPFire.org IPFire: before 2.27; 2.27-core_update159, 2.27-core_update160, 2.27-core_update161, 2.27-core_update162, 2.27-core_update163, 2.27-core_update164 (+3) — fixed in 2.27
How to fix
Upgrade to a fixed version: IPFire.org IPFire 2.27. Check the vendor advisory for mitigations.
References
- https://blog.ipfire.org/post/ipfire-2-27-core-update-170-released
- https://bugzilla.ipfire.org/show_bug.cgi?id=12925
- https://github.com/ipfire/ipfire-2.x
- https://jvn.jp/en/jp/JVN15411362/index.html
- https://blog.ipfire.org/post/ipfire-2-27-core-update-170-released
- https://bugzilla.ipfire.org/show_bug.cgi?id=12925
- https://github.com/ipfire/ipfire-2.x
- https://jvn.jp/en/jp/JVN15411362/index.html
Get alerted when CVE-2022-36368 or the next vulnerability affects your stack