What’s Vulnerable › Vulnerabilities
CVE-2022-36432
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The Preview functionality in the Amasty Blog Pro 2.10.3 plugin for Magento 2 uses eval unsafely. This allows attackers to perform Cross-site Scripting attacks on admin panel users by manipulating the generated preview application response.
Affected products
- Amasty Blog Pro: before 2.10.5 — fixed in 2.10.5
How to fix
Upgrade to a fixed version: Amasty Blog Pro 2.10.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-36432 or the next vulnerability affects your stack