What’s Vulnerable › Vulnerabilities
CVE-2022-36433
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The blog-post creation functionality in the Amasty Blog Pro 2.10.3 plugin for Magento 2 allows injection of JavaScript code in the short_content and full_content fields, leading to XSS attacks against admin panel users via posts/preview or posts/save.
Affected products
- Amasty Blog Pro: before 2.10.5 — fixed in 2.10.5
How to fix
Upgrade to a fixed version: Amasty Blog Pro 2.10.5. Check the vendor advisory for mitigations.
References
- https://github.com/afine-com/CVE-2022-36433
- https://weglow.ski
- https://github.com/afine-com/CVE-2022-36433
- https://weglow.ski
Get alerted when CVE-2022-36433 or the next vulnerability affects your stack