What’s Vulnerable › Vulnerabilities
CVE-2022-36436
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-14 · updated 2026-06-17
- Weakness: CWE-287
Description
OSU Open Source Lab VNCAuthProxy through 1.1.1 is affected by an vncap/vnc/protocol.py VNCServerAuthenticator authentication-bypass vulnerability that could allow a malicious actor to gain unauthorized access to a VNC session or to disconnect a legitimate user from a VNC session. A remote attacker with network access to the proxy server could leverage this vulnerability to connect to VNC servers protected by the proxy server without providing any authentication credentials. Exploitation of this issue requires that the proxy server is currently accepting connections for the target VNC server.
Affected products
- Osuosl Twisted Vnc Authentication Proxy: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: Osuosl Twisted Vnc Authentication Proxy 1.2.0. Check the vendor advisory for mitigations.
References
- https://cert.grnet.gr/en/blog/cve-2022-36436-twisted-vnc-authentication-proxy-authentication-bypass/
- https://github.com/osuosl/twisted_vncauthproxy/commit/edc149af29242178091b2d6fcd42c3ef0851644b
- https://github.com/osuosl/twisted_vncauthproxy/tree/release/1.1.1
- https://pypi.org/project/VNCAuthProxy/
- https://cert.grnet.gr/en/blog/cve-2022-36436-twisted-vnc-authentication-proxy-authentication-bypass/
- https://github.com/osuosl/twisted_vncauthproxy/commit/edc149af29242178091b2d6fcd42c3ef0851644b
- https://github.com/osuosl/twisted_vncauthproxy/tree/release/1.1.1
- https://pypi.org/project/VNCAuthProxy/
Get alerted when CVE-2022-36436 or the next vulnerability affects your stack