What’s Vulnerable › Vulnerabilities
CVE-2022-36437
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-29 · updated 2026-06-17
- Weakness: CWE-384
Description
The Connection handler in Hazelcast and Hazelcast Jet allows a remote unauthenticated attacker to access and manipulate data in the cluster with the identity of another already authenticated connection. The affected Hazelcast versions are through 4.0.6, 4.1.9, 4.2.5, 5.0.3, and 5.1.2. The affected Hazelcast Jet versions are through 4.5.3.
Affected products
- hazelcast: before 3.12.13; from 4.0.0 before 4.1.10; from 4.2.0 before 4.2.6; from 5.0.0 before 5.0.4; from 5.1.0 before 5.1.3 — fixed in 3.12.13, 4.1.10, 4.2.6, 5.0.4, 5.1.3
- Hazelcast-Jet: before 4.5.4 — fixed in 4.5.4
How to fix
Upgrade to a fixed version: hazelcast 3.12.13, 4.1.10, 4.2.6, 5.0.4; Hazelcast-Jet 4.5.4. Check the vendor advisory for mitigations.
References
- https://github.com/hazelcast/hazelcast/security/advisories/GHSA-c5hg-mr8r-f6jp
- https://github.com/hazelcast/hazelcast/security/advisories/GHSA-c5hg-mr8r-f6jp
Get alerted when CVE-2022-36437 or the next vulnerability affects your stack