What’s Vulnerable › Vulnerabilities
CVE-2022-3676
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-24 · updated 2026-06-17
- Weakness: CWE-20
Description
In Eclipse Openj9 before version 0.35.0, interface calls can be inlined without a runtime type check. Malicious bytecode could make use of this inlining to access or modify memory via an incompatible type.
Affected products
- The Eclipse Foundation Eclipse OpenJ9: before 0.35.0 — fixed in 0.35.0
How to fix
Upgrade to a fixed version: The Eclipse Foundation Eclipse OpenJ9 0.35.0. Check the vendor advisory for mitigations.
References
- https://github.com/eclipse-openj9/openj9/pull/16122
- https://github.com/eclipse/omr/pull/6773
- https://gitlab.eclipse.org/eclipsefdn/emo-team/emo/-/issues/389
- https://github.com/eclipse-openj9/openj9/pull/16122
- https://github.com/eclipse/omr/pull/6773
- https://gitlab.eclipse.org/eclipsefdn/emo-team/emo/-/issues/389
Get alerted when CVE-2022-3676 or the next vulnerability affects your stack