What’s Vulnerable › Vulnerabilities
CVE-2022-36760: Apache HTTP Server: mod_proxy_ajp Possible request smuggling
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-17 · updated 2026-06-17
- Weakness: CWE-444
Description
Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in mod_proxy_ajp of Apache HTTP Server allows an attacker to smuggle requests to the AJP server it forwards requests to. This issue affects Apache HTTP Server Apache HTTP Server 2.4 version 2.4.54 and prior versions.
Affected products
- Apache HTTP Server: from 2.4.0 before 2.4.55 — fixed in 2.4.55
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.4.55. Check the vendor advisory for mitigations.
References
- https://httpd.apache.org/security/vulnerabilities_24.html
- https://security.gentoo.org/glsa/202309-01
- https://httpd.apache.org/security/vulnerabilities_24.html
- https://security.gentoo.org/glsa/202309-01
Get alerted when CVE-2022-36760 or the next vulnerability affects your stack