What’s Vulnerable › Vulnerabilities

CVE-2022-36804: Atlassian Bitbucket Server and Data Center Command Injection Vulnerability

Description

Multiple API endpoints in Atlassian Bitbucket Server and Data Center 7.0.0 before version 7.6.17, from version 7.7.0 before version 7.17.10, from version 7.18.0 before version 7.21.4, from version 8.0.0 before version 8.0.3, from version 8.1.0 before version 8.1.3, and from version 8.2.0 before version 8.2.2, and from version 8.3.0 before 8.3.1 allows remote attackers with read permissions to a public or private Bitbucket repository to execute arbitrary code by sending a malicious HTTP request. This vulnerability was reported via our Bug Bounty Program by TheGrandPew.

Affected products

How to fix

Upgrade to a fixed version: Atlassian Bitbucket Server 7.17.10, 7.21.4, 7.6.17, 8.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-36804 or the next vulnerability affects your stack