What’s Vulnerable › Vulnerabilities
CVE-2022-3691: DeepL Pro API Translation < 1.7.5 - API Key Disclosure
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-21 · updated 2026-06-17
- Weakness: CWE-552
Description
The DeepL Pro API translation plugin WordPress plugin before 1.7.5 discloses sensitive information (including the DeepL API key) in files that are publicly accessible to an external, unauthenticated visitor.
Affected products
- DeepL Pro API translation plugin: before 1.7.5 — fixed in 1.7.5
How to fix
Upgrade to a fixed version: DeepL Pro API translation plugin 1.7.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/4248a0af-1b7e-4e29-8129-3f40c1d0c560
- https://wpscan.com/vulnerability/4248a0af-1b7e-4e29-8129-3f40c1d0c560
Get alerted when CVE-2022-3691 or the next vulnerability affects your stack