What’s Vulnerable › Vulnerabilities
CVE-2022-36937
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-10 · updated 2026-06-17
- Weakness: CWE-327
Description
HHVM 4.172.0 and all prior versions use TLS 1.0 for secure connections when handling tls:// URLs in the stream extension. TLS1.0 has numerous published vulnerabilities and is deprecated. HHVM 4.153.4, 4.168.2, 4.169.2, 4.170.2, 4.171.1, 4.172.1, 4.173.0 replaces TLS1.0 with TLS1.3. Applications that call stream_socket_server or stream_socket_client functions with a URL starting with tls:// are affected.
Affected products
- Facebook HHVM: before 4.153.4; from 4.154.0 before 4.168.2; from 4.169.0 before 4.169.2; from 4.170.0 before 4.170.2; 4.171.0, 4.172.0 — fixed in 4.153.4, 4.168.2, 4.169.2, 4.170.2
How to fix
Upgrade to a fixed version: Facebook HHVM 4.153.4, 4.168.2, 4.169.2, 4.170.2. Check the vendor advisory for mitigations.
References
- https://github.com/facebook/hhvm/commit/083f5ffdee661f61512909d16f9a5b98cff3cf0b
- https://hhvm.com/blog/2023/01/20/security-update.html
- https://github.com/facebook/hhvm/commit/083f5ffdee661f61512909d16f9a5b98cff3cf0b
- https://hhvm.com/blog/2023/01/20/security-update.html
Get alerted when CVE-2022-36937 or the next vulnerability affects your stack