What’s Vulnerable › Vulnerabilities
CVE-2022-36967
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-02 · updated 2026-06-17
- Weakness: CWE-79
Description
In Progress WS_FTP Server prior to version 8.7.3, multiple reflected cross-site scripting (XSS) vulnerabilities exist in the administrative web interface. It is possible for a remote attacker to inject arbitrary JavaScript into a WS_FTP administrator's web session. This would allow the attacker to execute code within the context of the victim's browser.
Affected products
- Progress Ipswitch Ws Ftp Server: before 8.7.3 — fixed in 8.7.3
How to fix
Upgrade to a fixed version: Progress Ipswitch Ws Ftp Server 8.7.3. Check the vendor advisory for mitigations.
References
- https://community.progress.com/s/article/WS-FTP-Server-Critical-Security-Product-Alert-Bulletin-June-2022
- https://www.progress.com/ws_ftp
- https://community.progress.com/s/article/WS-FTP-Server-Critical-Security-Product-Alert-Bulletin-June-2022
- https://www.progress.com/ws_ftp
Get alerted when CVE-2022-36967 or the next vulnerability affects your stack