What’s Vulnerable › Vulnerabilities
CVE-2022-36970
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-29 · updated 2026-06-17
- Weakness: CWE-356
Description
This vulnerability allows remote attackers to execute arbitrary code on affected installations of AVEVA Edge 20.0 Build: 4201.2111.1802.0000 Service Pack 2. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the processing of APP files. Crafted data in a APP file can cause the application to execute arbitrary Visual Basic scripts. The user interface fails to provide sufficient indication of the hazard. An attacker can leverage this vulnerability to execute code in the context of current process. Was ZDI-CAN-17370.
Affected products
- AVEVA Edge: before 2020.2.00.40 — fixed in 2020.2.00.40
How to fix
Upgrade to a fixed version: AVEVA Edge 2020.2.00.40. Check the vendor advisory for mitigations.
References
- https://www.aveva.com/content/dam/aveva/documents/support/cyber-security-updates/SecurityBulletin_AVEVA-2022-005.pdf
- https://www.zerodayinitiative.com/advisories/ZDI-22-1129/
- https://www.aveva.com/content/dam/aveva/documents/support/cyber-security-updates/SecurityBulletin_AVEVA-2022-005.pdf
- https://www.zerodayinitiative.com/advisories/ZDI-22-1129/
Get alerted when CVE-2022-36970 or the next vulnerability affects your stack