What’s Vulnerable › Vulnerabilities
CVE-2022-37011
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-13 · updated 2026-06-17
- Weakness: CWE-294
Description
A vulnerability has been identified in Mendix SAML (Mendix 7 compatible) (All versions < V1.17.0), Mendix SAML (Mendix 8 compatible) (All versions < V2.3.0), Mendix SAML (Mendix 9 compatible, New Track) (All versions < V3.3.1), Mendix SAML (Mendix 9 compatible, Upgrade Track) (All versions < V3.3.0). Affected versions of the module insufficiently protect from packet capture replay. This could allow unauthorized remote attackers to bypass authentication and get access to the application. For compatibility reasons, fix versions still contain this issue, but only when the not recommended, non default configuration option `'Allow Idp Initiated Authentication'` is enabled.
Affected products
- Siemens Mendix SAML Module: before 1.17.0; from 2.0.0 before 2.3.0; from 3.0.0 before 3.3.1 — fixed in 1.17.0, 2.3.0, 3.3.1
How to fix
Upgrade to a fixed version: Siemens Mendix SAML Module 1.17.0, 2.3.0, 3.3.1. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-638652.pdf
- https://cert-portal.siemens.com/productcert/pdf/ssa-638652.pdf
Get alerted when CVE-2022-37011 or the next vulnerability affects your stack