What’s Vulnerable › Vulnerabilities
CVE-2022-37021: Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 8.
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-31 · updated 2026-06-17
- Weakness: CWE-502
Description
Apache Geode versions up to 1.12.5, 1.13.4 and 1.14.0 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on Java 8. Any user still on Java 8 who wishes to protect against deserialization attacks involving JMX or RMI should upgrade to Apache Geode 1.15 and Java 11. If upgrading to Java 11 is not possible, then upgrade to Apache Geode 1.15 and specify "--J=-Dgeode.enableGlobalSerialFilter=true" when starting any Locators or Servers. Follow the documentation for details on specifying any user classes that may be serialized/deserialized with the "serializable-object-filter" configuration option. Using a global serial filter will impact performance.
Affected products
- Apache Software Foundation Apache Geode: through 1.12.5; from 1.13.0 through 1.13.4; 1.14.0
References
- https://lists.apache.org/thread/qrvhmytsshsk5xcb68pwccw3y6m8o8nr
- https://lists.apache.org/thread/qrvhmytsshsk5xcb68pwccw3y6m8o8nr
Get alerted when CVE-2022-37021 or the next vulnerability affects your stack