What’s Vulnerable › Vulnerabilities
CVE-2022-37022: Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 11
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-31 · updated 2026-06-17
- Weakness: CWE-502
Description
Apache Geode versions up to 1.12.2 and 1.13.2 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on Java 11. Any user wishing to protect against deserialization attacks involving JMX or RMI should upgrade to Apache Geode 1.15. Use of 1.15 on Java 11 will automatically protect JMX over RMI against deserialization attacks. This should have no impact on performance since it only affects JMX/RMI which Gfsh uses to communicate with the JMX Manager which is hosted on a Locator.
Affected products
- Apache Software Foundation Apache Geode: through 1.12.2; from 1.13.0 through 1.13.2
References
- https://lists.apache.org/thread/kr1y4l9752g1ww1shnmh8dbfjq785k4m
- https://lists.apache.org/thread/kr1y4l9752g1ww1shnmh8dbfjq785k4m
Get alerted when CVE-2022-37022 or the next vulnerability affects your stack