What’s Vulnerable › Vulnerabilities
CVE-2022-37023: Apache Geode deserialization of untrusted data flaw when using REST API on Java 8 or Java 11
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-31 · updated 2026-06-17
- Weakness: CWE-502
Description
Apache Geode versions prior to 1.15.0 are vulnerable to a deserialization of untrusted data flaw when using REST API on Java 8 or Java 11. Any user wishing to protect against deserialization attacks involving REST APIs should upgrade to Apache Geode 1.15 and follow the documentation for details on enabling "validate-serializable-objects=true" and specifying any user classes that may be serialized/deserialized with "serializable-object-filter". Enabling "validate-serializable-objects" may impact performance.
Affected products
- Apache Software Foundation Apache Geode: before 1.15.0 — fixed in 1.15.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Geode 1.15.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/6js89pbqrp52zlpwgry5fsdn76gxbbfj
- https://lists.apache.org/thread/6js89pbqrp52zlpwgry5fsdn76gxbbfj
Get alerted when CVE-2022-37023 or the next vulnerability affects your stack