What’s Vulnerable › Vulnerabilities
CVE-2022-37032
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-19 · updated 2026-06-17
- Weakness: CWE-125
Description
An out-of-bounds read in the BGP daemon of FRRouting FRR before 8.4 may lead to a segmentation fault and denial of service. This occurs in bgp_capability_msg_parse in bgpd/bgp_packet.c.
Affected products
- Debian Linux: 10.0, 11.0
- FRRouting: before 8.4 — fixed in 8.4
How to fix
Upgrade to a fixed version: FRRouting 8.4. Check the vendor advisory for mitigations.
References
- https://bugzilla.suse.com/show_bug.cgi?id=1202023
- https://github.com/FRRouting/frr/commit/6d58272b4cf96f0daa846210dd2104877900f921
- https://github.com/FRRouting/frr/commit/ff6db1027f8f36df657ff2e5ea167773752537ed
- https://lists.debian.org/debian-lts-announce/2022/11/msg00039.html
- https://www.debian.org/security/2023/dsa-5362
- https://bugzilla.suse.com/show_bug.cgi?id=1202023
- https://github.com/FRRouting/frr/commit/6d58272b4cf96f0daa846210dd2104877900f921
- https://github.com/FRRouting/frr/commit/ff6db1027f8f36df657ff2e5ea167773752537ed
- https://lists.debian.org/debian-lts-announce/2022/11/msg00039.html
- https://www.debian.org/security/2023/dsa-5362
Get alerted when CVE-2022-37032 or the next vulnerability affects your stack