What’s Vulnerable › Vulnerabilities
CVE-2022-3705: vim autocmd quickfix.c qf_update_buffer use after free
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-26 · updated 2026-06-17
- Weakness: CWE-119
Description
A vulnerability was found in vim and classified as problematic. Affected by this issue is the function qf_update_buffer of the file quickfix.c of the component autocmd Handler. The manipulation leads to use after free. The attack may be launched remotely. Upgrading to version 9.0.0805 is able to address this issue. The name of the patch is d0fab10ed2a86698937e3c3fed2f10bd9bb5e731. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-212324.
Affected products
- Debian Linux: 10.0
- Fedoraproject Fedora: 35, 36
- Active IQ Unified Manager for VMware vSphere, Linux, and Microsoft Windows: all versions
- vim/vim: before 9.0.0805 — fixed in 9.0.0805
How to fix
Upgrade to a fixed version: vim/vim 9.0.0805. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2023/Jan/19
- https://github.com/vim/vim/commit/d0fab10ed2a86698937e3c3fed2f10bd9bb5e731
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4JCW33NOLMELTTTDJH7WGDIFJZ5YEEMK/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GTBVD4J2SKVSWK4VBN5JP5OEVK6GDS3N/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JYEK5RNMH7MVQH6RPBKLSCCA6NMIKHDV/
- https://security.gentoo.org/glsa/202305-16
- https://security.netapp.com/advisory/ntap-20221223-0004/
- https://support.apple.com/kb/HT213605
- https://vuldb.com/?id.212324
- http://seclists.org/fulldisclosure/2023/Jan/19
- https://github.com/vim/vim/commit/d0fab10ed2a86698937e3c3fed2f10bd9bb5e731
Get alerted when CVE-2022-3705 or the next vulnerability affects your stack