What’s Vulnerable › Vulnerabilities

CVE-2022-3706

Description

Improper authorization in GitLab CE/EE affecting all versions from 7.14 prior to 15.3.5, 15.4 prior to 15.4.4, and 15.5 prior to 15.5.2 allows a user retrying a job in a downstream pipeline to take ownership of the retried jobs in the upstream pipeline even if the user doesn't have access to that project.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.3.5, 15.4.4, 15.5.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-3706 or the next vulnerability affects your stack