What’s Vulnerable › Vulnerabilities
CVE-2022-3708: Web Stories <= 1.24.0 - Server Side Request Forgery
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-28 · updated 2026-06-17
- Weakness: CWE-918
Description
The Web Stories plugin for WordPress is vulnerable to Server-Side Request Forgery in versions up to, and including 1.24.0 due to insufficient validation of URLs supplied via the 'url' parameter found via the /v1/hotlink/proxy REST API Endpoint. This makes it possible for authenticated users to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
Affected products
- google Web Stories: before 1.25.0 — fixed in 1.25.0
How to fix
Upgrade to a fixed version: google Web Stories 1.25.0. Check the vendor advisory for mitigations.
References
- https://github.com/GoogleForCreators/web-stories-wp/commit/3ad2099f95155d658624ffac2e34ce0da739e34b
- https://github.com/GoogleForCreators/web-stories-wp/compare/v1.24.0...v1.25.0
- https://wordpress.org/plugins/web-stories
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7817a840-325a-4709-8374-84bb32d98d0e?source=cve
- https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-3708
- https://github.com/GoogleForCreators/web-stories-wp/commit/3ad2099f95155d658624ffac2e34ce0da739e34b
- https://github.com/GoogleForCreators/web-stories-wp/compare/v1.24.0...v1.25.0
- https://wordpress.org/plugins/web-stories
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7817a840-325a-4709-8374-84bb32d98d0e?source=cve
- https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-3708
Get alerted when CVE-2022-3708 or the next vulnerability affects your stack