What’s Vulnerable › Vulnerabilities
CVE-2022-3710
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-01 · updated 2026-06-17
- Weakness: CWE-89
Description
A post-auth read-only SQL injection vulnerability allows API clients to read non-sensitive configuration database contents in the API controller of Sophos Firewall releases older than version 19.5 GA.
Affected products
- Sophos Xg Firewall Firmware: before 19.5 — fixed in 19.5
How to fix
Upgrade to a fixed version: Sophos Xg Firewall Firmware 19.5. Check the vendor advisory for mitigations.
References
- https://www.sophos.com/en-us/security-advisories/sophos-sa-20221201-sfos-19-5-0
- https://www.sophos.com/en-us/security-advisories/sophos-sa-20221201-sfos-19-5-0
Get alerted when CVE-2022-3710 or the next vulnerability affects your stack