What’s Vulnerable › Vulnerabilities
CVE-2022-3715
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-05 · updated 2026-10-14
- Weakness: CWE-119
Description
A flaw was found in the bash package, where a heap-buffer overflow can occur in valid parameter_transform. This issue may lead to memory problems.
Affected products
- GNU Bash: from 5.1 before 5.1.8 — fixed in 5.1.8
- Red Hat Enterprise Linux: 9.0
How to fix
Upgrade to a fixed version: GNU Bash 5.1.8. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2126720
- https://bugzilla.redhat.com/show_bug.cgi?id=2126720
- https://security.netapp.com/advisory/ntap-20241108-0002/
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
Get alerted when CVE-2022-3715 or the next vulnerability affects your stack