What’s Vulnerable › Vulnerabilities
CVE-2022-37325
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-05 · updated 2026-07-02
- Weakness: CWE-787
Description
In Sangoma Asterisk through 16.28.0, 17.x and 18.x through 18.14.0, and 19.x through 19.6.0, an incoming Setup message to addons/ooh323c/src/ooq931.c with a malformed Calling or Called Party IE can cause a crash.
Affected products
- asterisk: from 16.0.0 before 16.29.1; from 18.0.0 before 18.15.1; from 19.0.0 before 19.7.1; 20.0.0 — fixed in 16.29.1, 18.15.1, 19.7.1
How to fix
Upgrade to a fixed version: asterisk 16.29.1, 18.15.1, 19.7.1. Check the vendor advisory for mitigations.
References
- https://downloads.asterisk.org/pub/security/AST-2022-007.html
- https://lists.debian.org/debian-lts-announce/2023/02/msg00029.html
- https://www.debian.org/security/2023/dsa-5358
- http://seclists.org/fulldisclosure/2026/Jul/2
- http://seclists.org/fulldisclosure/2026/Jul/4
- http://seclists.org/fulldisclosure/2026/Jul/6
- http://seclists.org/fulldisclosure/2026/Jul/7
- https://downloads.asterisk.org/pub/security/AST-2022-007.html
- https://lists.debian.org/debian-lts-announce/2023/02/msg00029.html
- https://www.debian.org/security/2023/dsa-5358
Get alerted when CVE-2022-37325 or the next vulnerability affects your stack