What’s Vulnerable › Vulnerabilities
CVE-2022-37383
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-29 · updated 2026-06-17
- Weakness: CWE-125
Description
This vulnerability allows remote attackers to disclose sensitive information on affected installations of Foxit PDF Reader 11.2.1.53537. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the handling of Doc objects. By performing actions in JavaScript, an attacker can trigger a read past the end of an allocated object. An attacker can leverage this in conjunction with other vulnerabilities to execute arbitrary code in the context of the current process. Was ZDI-CAN-17111.
Affected products
- Foxit PDF Reader: before 10.1.9; from 11.0.0 before 11.2.3; 12.0.0.12394 — fixed in 10.1.9, 11.2.3
- Foxit Pdf Reader: before 12.0.1 — fixed in 12.0.1
How to fix
Upgrade to a fixed version: Foxit PDF Reader 10.1.9, 11.2.3; Foxit Pdf Reader 12.0.1. Check the vendor advisory for mitigations.
References
- https://www.foxit.com/support/security-bulletins.html
- https://www.zerodayinitiative.com/advisories/ZDI-22-1055/
- https://www.foxit.com/support/security-bulletins.html
- https://www.zerodayinitiative.com/advisories/ZDI-22-1055/
Get alerted when CVE-2022-37383 or the next vulnerability affects your stack