What’s Vulnerable › Vulnerabilities
CVE-2022-37391
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-29 · updated 2026-06-17
- Weakness: CWE-416
Description
This vulnerability allows remote attackers to execute arbitrary code on affected installations of Foxit PDF Reader 11.2.2.53575. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the handling of AcroForms. The issue results from the lack of validating the existence of an object prior to performing operations on the object. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-17661.
Affected products
- Foxit PDF Reader: before 10.1.9; from 11.0.0 before 11.2.3; 12.0.0.12394 — fixed in 10.1.9, 11.2.3
- Foxit Pdf Reader: before 12.0.1 — fixed in 12.0.1
How to fix
Upgrade to a fixed version: Foxit PDF Reader 10.1.9, 11.2.3; Foxit Pdf Reader 12.0.1. Check the vendor advisory for mitigations.
References
- https://www.foxit.com/support/security-bulletins.html
- https://www.zerodayinitiative.com/advisories/ZDI-22-1063/
- https://www.foxit.com/support/security-bulletins.html
- https://www.zerodayinitiative.com/advisories/ZDI-22-1063/
Get alerted when CVE-2022-37391 or the next vulnerability affects your stack