What’s Vulnerable › Vulnerabilities
CVE-2022-3740
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-26 · updated 2026-06-17
- Weakness: CWE-285
Description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 12.9 prior to 15.3.5, 15.4 prior to 15.4.4, and 15.5 prior to 15.5.2. A group owner may be able to bypass External Authorization check, if it is enabled, to access git repositories and package registries by using Deploy tokens or Deploy keys .
Affected products
- GitLab: from 12.9.0 before 15.4.6; from 15.5.0 before 15.5.5; 15.6.0 — fixed in 15.4.6, 15.5.5
How to fix
Upgrade to a fixed version: GitLab 15.4.6, 15.5.5. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-3740.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/368416
- https://hackerone.com/reports/1602904
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-3740.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/368416
- https://hackerone.com/reports/1602904
Get alerted when CVE-2022-3740 or the next vulnerability affects your stack