What’s Vulnerable › Vulnerabilities

CVE-2022-37434

Description

zlib through 1.2.12 has a heap-based buffer over-read or buffer overflow in inflate in inflate.c via a large gzip header extra field. NOTE: only applications that call inflateGetHeader are affected. Some common applications bundle the affected zlib source code but may be unable to call inflateGetHeader (e.g., see the nodejs/node reference).

Affected products

How to fix

Upgrade to a fixed version: Apple iPadOS 15.7.1; Apple Iphone Os 15.7.1, 16.1; Apple macOS 11.7.1, 12.6.1; Apple watchOS 9.1; Stormshield Network Security 3.11.22, 3.7.34, 4.3.16, 4.6.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-37434 or the next vulnerability affects your stack