What’s Vulnerable › Vulnerabilities
CVE-2022-37436: Apache HTTP Server: mod_proxy prior to 2.4.55 allows a backend to trigger HTTP response splitting
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 55.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-17 · updated 2026-06-17
- Weakness: CWE-113
Description
Prior to Apache HTTP Server 2.4.55, a malicious backend can cause the response headers to be truncated early, resulting in some headers being incorporated into the response body. If the later headers have any security purpose, they will not be interpreted by the client.
Affected products
- Apache HTTP Server: before 2.4.55 — fixed in 2.4.55
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.4.55. Check the vendor advisory for mitigations.
References
- https://httpd.apache.org/security/vulnerabilities_24.html
- https://security.gentoo.org/glsa/202309-01
- https://httpd.apache.org/security/vulnerabilities_24.html
- https://security.gentoo.org/glsa/202309-01
Get alerted when CVE-2022-37436 or the next vulnerability affects your stack