What’s Vulnerable › Vulnerabilities
CVE-2022-37451
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-06 · updated 2026-06-17
- Weakness: CWE-763
Description
Exim before 4.96 has an invalid free in pam_converse in auths/call_pam.c because store_free is not used after store_malloc.
Affected products
- Exim: before 4.96 — fixed in 4.96
- Fedoraproject Fedora: 35, 36
How to fix
Upgrade to a fixed version: Exim 4.96. Check the vendor advisory for mitigations.
References
- https://cwe.mitre.org/data/definitions/762.html
- https://github.com/Exim/exim/commit/51be321b27825c01829dffd90f11bfff256f7e42
- https://github.com/Exim/exim/compare/exim-4.95...exim-4.96
- https://github.com/Exim/exim/wiki/EximSecurity
- https://github.com/ivd38/exim_invalid_free
- https://lists.exim.org/lurker/message/20220625.141825.d6de6074.en.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LETR5CVDPFOFQHXCJP6NFLG52JZHQYDY/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XSWDF4QEXD4TDWQLYQOWCHBJKTDQR4Z7/
- https://www.exim.org/static/doc/security/
- https://www.openwall.com/lists/oss-security/2022/08/06/1
- https://cwe.mitre.org/data/definitions/762.html
- https://github.com/Exim/exim/commit/51be321b27825c01829dffd90f11bfff256f7e42
Get alerted when CVE-2022-37451 or the next vulnerability affects your stack