What’s Vulnerable › Vulnerabilities

CVE-2022-3758

Description

An issue has been discovered in GitLab affecting all versions starting from 15.5 before 15.7.8, all versions starting from 15.8 before 15.8.4, all versions starting from 15.9 before 15.9.2. Due to improper permissions checks an unauthorised user was able to read, add or edit a users private snippet.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.7.8, 15.8.4, 15.9.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-3758 or the next vulnerability affects your stack