What’s Vulnerable › Vulnerabilities
CVE-2022-3759
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-13 · updated 2026-06-17
- Weakness: CWE-400
Description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 14.3 before 15.6.7, all versions starting from 15.7 before 15.7.6, all versions starting from 15.8 before 15.8.1. An attacker may upload a crafted CI job artifact zip file in a project that uses dynamic child pipelines and make a sidekiq job allocate a lot of memory. In GitLab instances where Sidekiq is memory-limited, this may cause Denial of Service.
Affected products
- GitLab: from 14.3 before 15.6.7; from 15.7 before 15.7.6; from 15.8 before 15.8.1 — fixed in 15.6.7, 15.7.6, 15.8.1
How to fix
Upgrade to a fixed version: GitLab 15.6.7, 15.7.6, 15.8.1. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-3759.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/379633
- https://hackerone.com/reports/1736230
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-3759.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/379633
- https://hackerone.com/reports/1736230
- https://gitlab.com/gitlab-org/gitlab/-/issues/379633
Get alerted when CVE-2022-3759 or the next vulnerability affects your stack