What’s Vulnerable › Vulnerabilities
CVE-2022-3766: Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-31 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Reflected in GitHub repository thorsten/phpmyfaq prior to 3.1.8.
Affected products
- thorsten phpMyFAQ: before 3.1.8 — fixed in 3.1.8
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 3.1.8. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpmyfaq/commit/c7904f2236c6c0dd64c2226b90c30af0f7e5a72d
- https://huntr.dev/bounties/d9666520-4ff5-43bb-aacf-50c8e5570983
- https://github.com/MarkLee131/awesome-web-pocs/blob/main/CVE-2022-3766.md
- https://github.com/thorsten/phpmyfaq/commit/c7904f2236c6c0dd64c2226b90c30af0f7e5a72d
- https://huntr.dev/bounties/d9666520-4ff5-43bb-aacf-50c8e5570983
Get alerted when CVE-2022-3766 or the next vulnerability affects your stack