What’s Vulnerable › Vulnerabilities
CVE-2022-3776: Restaurant Menu – Food Ordering System – Table Reservation <= 2.3.1 - Cross-Site Request Forgery
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-03 · updated 2026-06-17
- Weakness: CWE-352
Description
The Restaurant Menu – Food Ordering System – Table Reservation plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.3.1. This is due to missing or incorrect nonce validation on several functions called via AJAX actions such as forms_action, set_option, & chosen_options to name a few . This makes it possible for unauthenticated attackers to perform a variety of administrative actions like modifying forms, via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- gloriafood Restaurant Menu – Food Ordering System – Table Reservation: before 2.3.2 — fixed in 2.3.2
How to fix
Upgrade to a fixed version: gloriafood Restaurant Menu – Food Ordering System – Table Reservation 2.3.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2807967%40menu-ordering-reservations&new=2807967%40menu-ordering-reservations&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/67fe46cd-a6c4-4d0a-842a-f61334559731?source=cve
- https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-3776
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2807967%40menu-ordering-reservations&new=2807967%40menu-ordering-reservations&sfp_email=&sfph_mail=
- https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-3776
Get alerted when CVE-2022-3776 or the next vulnerability affects your stack