What’s Vulnerable › Vulnerabilities
CVE-2022-3783: node-red-dashboard ui_text Format ui-component-ctrl.js cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-31 · updated 2026-06-17
- Weakness: CWE-707
Description
A vulnerability, which was classified as problematic, has been found in node-red-dashboard. This issue affects some unknown processing of the file components/ui-component/ui-component-ctrl.js of the component ui_text Format Handler. The manipulation leads to cross site scripting. The attack may be initiated remotely. The name of the patch is 9305d1a82f19b235dfad24a7d1dd4ed244db7743. It is recommended to apply a patch to fix this issue. The associated identifier of this vulnerability is VDB-212555.
Affected products
- node-red-dashboard: before 3.2.0 — fixed in 3.2.0
How to fix
Upgrade to a fixed version: node-red-dashboard 3.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/node-red/node-red-dashboard/commit/9305d1a82f19b235dfad24a7d1dd4ed244db7743
- https://github.com/node-red/node-red-dashboard/issues/772
- https://vuldb.com/?id.212555
- https://github.com/node-red/node-red-dashboard/commit/9305d1a82f19b235dfad24a7d1dd4ed244db7743
- https://github.com/node-red/node-red-dashboard/issues/772
- https://vuldb.com/?id.212555
Get alerted when CVE-2022-3783 or the next vulnerability affects your stack